Follow

Restoring an iPhone 6 from an older iPhone causes the SoftToken

Important: With Apple's release of iOS 11 (64-bit), your existing AuthAnvil SoftToken (32-bit) will not work on any Apple devices running iOS 11 or higher.

AuthAnvil On-Prem customers who were using the SoftToken application should upgrade to the full AuthAnvil Authenticator application prior to their users upgrading to iOS 11. 

To perform this upgrade migration from AuthAnvil SoftToken to AuthAnvil Authenticator, it is necessary to reassign your users’ existing tokens. 

Please Note: You must perform both steps – referencing the links above – to successfully migrate apps and ensure compatibility with iOS 11.

 

Issue

After upgrading an iPhone from an older version to iPhone 6, the AuthAnvil SoftToken is either requesting to be activated or not opening properly.

If you have performed a backup using iCloud Backup from an older iPhone 5/5s, 4/4s etc and attempted to restore the app on an iPhone 6 (plus) you may see the following error when you select "Get password".

image1.PNG

 

 

Cause

AuthAnvil SoftTokens are tied to the device, not the OS. When you move to new hardware you will get new device information like a new IMEI, a new SIM card ID and various other attributes used to protect your SoftToken. When the SoftToken sees a mismatch the application will close down and fail securely, not allowing you to get access to the key cipher material as the information originally used doesn't match.

 

Resolution

Whenever you move to new hardware, you need to activate a new SoftToken.

  1. The SoftToken will need to be reset following the steps in this article
  2. Assign a SoftToken and have the user complete the steps in the self-enrollment email.

 

Affects

All iPhones 6 (plus) that have been restored from an older device using the AuthAnvil SoftToken app.

 

Questions?

If you have any questions or need some help, we would be happy to assist. Open a case at help.scorpionsoft.com or send an email to support@scorpionsoft.com.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk