Follow

Error 500.21 after installing Password Server

Issue

After installing the Password Server Browser the following error will display.

HTTP Error 500.21  - Internal Server Error

Handler "PageHandlerFactory-Integrated" has a bad module "ManagedPipelineHandler" in its module list.

50021.png

 

Cause

This error occurs because the Microsoft .NET Framework 4.0 configuration for ASP .NET has been damaged.

 

Resolution

To resolve this error, you must repair the .NET Framework 4.0.30319 version at a command prompt. 

Note: Run the following commands from an elevated Command Prompt (run as Administrator).


Perform a silent repair of the 4.0 .NET Framework.

For 32 bit servers with .Net Framework version 4.0.30319:

%windir%\Microsoft.NET\Framework\v4.0.30319\SetupCache\Client\setup.exe /repair /x86 /x64 /ia64 /parameterfolder Client /q /norestart

For 64 bit servers with .Net Framework version 4.0.30319:

%windir%\Microsoft.NET\Framework64\v4.0.30319\SetupCache\Client\setup.exe /repair /x86 /x64 /ia64 /parameterfolder Client /q /norestart



Install the ASP.NET version and configure IIS to use it

For 32 bit servers run the command:

%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe /iru

For 64 bit servers run the command:

%windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe /iru

 

 

Affects

AuthAnvil Password Server all versions unless other wise noted.


Questions?

If you have any questions or need some help, we would be happy to assist. Open a case at help.scorpionsoft.com or send an email to support@scorpionsoft.com.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk