Follow

After restoring AuthAnvil SSO, navigating to SSO portal throws error "Keyset does not exist"

Issue

After restoring AuthAnvil Single Sign On from a backup file, navigating to the SSO portal (yourdomain.com/SSO) throws the following error:

Server Error in '/SSO' Application.

The composition produced a single composition error. The root cause is provided below. Review the CompositionException.Errors property for more detailed information.

1) Keyset does not exist

  SSO_20-_20Keyset_20does_20not_20exist.png

 

Cause

The permissions for the SSO certificate are not properly set.

 

Resolution

Verify the permissions for the certificate in the Certificates snap-in for Microsoft Management Console.

  1. Press "Windows + R" then type "mmc" and press Enter.  This will load the Microsoft Management Console.
  2. In the console, select File > Add/Remove Snap-in...
  3. Select Certificates and click Add
  4. In the Certificate snap-in window select Computer account
  5. Select Local computer and click Finish
  6. Click Ok to load this snap-in
  7. Expand the Certificates (Local Computer) > Personal > Certificates menu
  8. Right-click the AuthAnvil Single Sign On Root Certificate*and select All Tasks > Manage Private Keys...
  9. Confirm that Full Control is set for "SYSTEM" and Read permissions are set for "NETWORK SERVICE", then click Ok
  10. Run an IISreset or reset the AuthAnvilSSO application pool in IIS

*There may be multiple certificates with the same name.  Apply Steps 8 and 9 to all of them.

At this point the certificate permissions will be refreshed and the problem should be resolved.
 

Affects

AuthAnvil Single Sign On v3.0 or later

 

Questions?

If you have any questions or need some help, we would be happy to assist. Open a case at help.scorpionsoft.com or send an email to support@scorpionsoft.com.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk