How can I upgrade VSA when I have existing integrations

If you are upgrading VSA from v6.5 or older to v7 or newer you will want to follow this process.

Note: As of VSA v8 patch 12 Microsoft .NET v4.5.1 or newer is required to be installed on the VSA server.


Step 1

If you have any older Addins installed please uninstall them from Programs and Features prior to the VSA upgrade.
Note: This step is mandatory or VSA logons will fail after the upgrade. The v4.2 and older Addins are not compatible.

If you are using the older Logon agent or Management Pack. Delete this folder "c:\Kaseya\Webpages\Authanvil". As well remove this file "c:\Kaseya\Webpages\Install\kaddon_authanvil.xml".


Step 2 

Remove the DB following this article
Note: This must be done before proceeding as the old AuthAnvil tables are not compatible with v7 or v8.

Paid Addin

If you have a valid subscription to the Paid addin please contact Support to obtain the newest version and specify what version of VSA you are upgrading to.

To verify if you have paid for the Addin please log into

Check your monthly statement you should see the following either a monthly reoccurring charge, or an annual charge.

Description Quantity    
Kaseya AddIn 1    

If you are not able to verify the Subscription please contact your Account Manager via


Free Logon Agent and Management Pack

Please follow the steps in this guide to implement the logon protection

Please follow this guide if you would like implement the Management Pack


What is the difference between the two integration's?

Check out this article This explains the differences in the integration.



If you have any questions or need some help, we would be happy to assist. Open a case at or send an email to


Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request


Powered by Zendesk