Follow

Installing 2FA Addin for Kaseya fails on Kaseya 6.3 (Legacy)

Note: This KB article originally applied to the controlled release of Kaseya v6.3. If you are running the full release of Kaseya 6.3 you may wish to review the KB article titled: 2FA Addin fails to install on Kaseya 6.3
 

Issue

When installing the 2FA Addin for Kaseya on the controlled release of Kaseya 6.3 you see this error message: "This Addin requires version 6.x of the Kaseya server. Setup will now exit"

Cause 

The installer is looking for a regkey which has been modified on 64-bit Kaseya installs, between versions 6.2 and 6.3.

 

Resolution

Our installer is expecting the value vsaPres to obtain the Kaseya version number, previously located here:

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\KServer.Exe

In order to resolve the conflict a new registry key will need to be created at the above location, including all key paths. The key value can be copied from the new location:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths\KServer.exe

Once you have copied the value from vsaPres in the second location and recreated it in the expected path the installer will run successfully.

Note: Standard registry warnings apply. Please do not modify any registry values if you are not familiar with these steps. Contact us our support staff and fill out a case for assistance.

 

Affects

2FA Addin for Kaseya installing on Kaseya 6.3

 

Questions?

If you have any questions or need some help, we would be happy to assist. Open a case at help.scorpionsoft.com or send an email to support@scorpionsoft.com.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk