Follow

PWS Addin pages display HTTP Error 500.19 in Kaseya (Legacy)

Issue

When navigating to any of the pages inside the AuthAnvil Password Server Addin, the following error appears in the frame:

HTTP Error 500.19 - Internal Server Error The requested page cannot be accessed because the related configuration data for the page is invalid.

Config Source:

105: <handlers accessPolicy="Read,Script">

106: <add name="ScriptResourceIntegrated-4.0" path="ScriptResource.axd" verb="GET,HEAD" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=4.0.0.0,Culture=neutral, PublicKeyToken=31BF3856AD364E35" preCondition="integratedMode,runtimeVersionv4.0" />

107: </handlers>

 

Cause

In Kaseya's configuration is a line of code that is also used in our PWS Addin. There is a conflict between the two lines and the configuration for the addin is not loaded.

 

Resolution

To resolve the conflict with our configuration file the line will need to be removed from < Kaseya Install >\WebPages\AAPS_Addin\web.config.

  1. Back up the AAPS_Addin\web.config file to make sure you can revert back if needed
  2. Delete the section from <handers accessPolicy="Read,Script"> to </handlers> which can be found close to line 106 in the file
  3. Save the file and reload the page within Kaseya. The 500.19 Errors should be gone

  

Affects

All versions of the PWS Addin on Kaseya 6.2 or 6.3

Questions?

If you have any questions or need some help, we would be happy to assist. Open a case at help.scorpionsoft.com or send an email to support@scorpionsoft.com.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk